Back to overview
Degraded

Temporary Service Interruption (Redis)

Nov 06 at 08:35am HST
Affected services
Citapro Api
Citapro workers

Resolved
Nov 06 at 10:16am HST

Earlier today, we experienced an issue in our infrastructure that affected Redis, which handles queued events in CitaPro.

As a result, some users encountered errors when creating or updating appointments, services, or performing other actions that rely on our event queue system. The incident was caused by a connection failure with Redis, which temporarily prevented proper processing of these operations.

Our technical team identified and resolved the issue within approximately 20 minutes, fully restoring system stability.

🔍 Corrective and Preventive Actions

Implemented additional proactive monitoring for Redis to detect connection drops or service disruptions in real time.

Adjusted automatic reconnection and early-warning alerts to prevent similar interruptions.

Evaluating redundancy improvements in the cache and queue layers to ensure higher availability.

We sincerely apologize for any inconvenience this may have caused and appreciate your understanding.
Our team remains fully committed to providing a reliable and high-performance service for all CitaPro customers.

Created
Nov 06 at 08:35am HST

We are currently investigating an issue affecting our Redis service, which is causing errors when saving or updating appointments, services, and other operations that rely on queued events.

Our engineering team has identified that the problem is related to Redis connection failures and is actively working to restore normal functionality.

Some users may experience intermittent errors or temporary unavailability when performing actions that interact with the queue system.

We’ll share updates as soon as we have more information.